I suggest you ...

Increase linux compatibilty

Using Livemocha on Ubuntu is a pain. Many people with agree with this. Please help us enjoy your site.

274 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    anonymousanonymous shared this idea  ·   ·  Admin →
    Anonymous shared a merged idea: Make it possible to upload previously saved audio  ·   · 
    Anonymous shared a merged idea: Use a version of flash that is natively compatible with Linux.  ·   · 
    ElenaElena shared a merged idea: It's not possible to use site since you upgraded Flash up to 11.4 :( Adobe supports only 11.2 for Linux  ·   · 
    AnonymousAnonymous shared a merged idea: Sound submissions not Working on Linux  ·   · 

    41 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • LinuxUserUnsupportedLinuxUserUnsupported commented  · 

        A site with flash support required. It is almost 2014. Are you moving back in time at livemocha?

        Well, together with 'Linux support in progress' (It's a fricking WEB PAGE. The web was DESIGNED to make things platform independent!!! You actually HAVE to spend additional time to make it locked down for only two OSes </rant>). I am done with this site.

      • Anonymous commented  · 

        With Firefox download this extension: https://addons.mozilla.org/en-us/firefox/addon/user-agent-switcher/

        Add the following user agent to its preferences: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.2 Safari/537.36

        Then on the livemocha site select that user agent.

        You should then be able to login.

        I'm using flash version 11,2,202,297. Everything works except microphone.

      • Eugene NightmarrrEugene Nightmarrr commented  · 

        I'm using it on debian wheezy, all goes OK. I've only changed my browser's UA to some windows UA to get possibility to log in.

      • Martin VMartin V commented  · 

        For linux users: Change the User Agent string to something like this:

        Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.2 Safari/537.36

        In chrome it's easy. Press F12, click the small gear-icon in the lower right corner. Go to Overrides, check User Agent, choose Other in the drop-down, and paste the string above.
        The new version of LM has a terrible javascript memory leak, it sucks up all my memory at once. Somehow I got past the login-screen, and was able to choose 'legacy mode'.

      • Anonymous commented  · 

        Same here, Livemocha doesn't work on Ubuntu 12.04. Funny thing is, that it did work on Ubuntu one or two years ago, when I first signed up. Everything worked just fine, the audio features, even recording from headphones worked. So somebody seemed to made the decision to remove a feature that is already there, for no obvious reasons. I wonder what that person thought? "You know what, let's ditch the Linux users. We will have to rework the site, yes, and we will loose about 3% of our users, but hey, that new plattform-dependent plattform just looks shiny!"

      • RaulRaul commented  · 

        Same problem as well. Flash does not work so I do not user Livemocha for the moment :(

      • Anonymous commented  · 

        I cannot us e LiveMocha because of the Flash requirement.
        So I won't help anybody and wiil end stopping to use it.

      • MellandaMellanda commented  · 

        i have the same problem, why are you so ignorant livemocha?

      • alvarkoalvarko commented  · 

        For archlinux and chromium browser:

        Install chromium-pepper-flash (or chromium-pepper-flash-stable) from aur

        Disable all other flash plugins:
        Type chrome://plugins/ in the adress bar and press Enter
        Click on Details button on the top right
        Click on Disable near all the Flash plugins except the first one

      • AnonymousAnonymous commented  · 

        Better, get rid of flash (but if you could just disable that lousy test…)

      • AnonymousAnonymous commented  · 

        So how's the porting to flash 11.2 going?.. Wanted to correct an exercice today. I won't, cause I can't !!

      • Anonymous commented  · 

        This is ridiculous. Users (many of them paying users) being ignored because they use Linux. Can I get a refund?

      • LorenzoLorenzo commented  · 

        PLEASE READ :)

        For anyone having problems watching the videos...follow these simple steps:

        1) Open the source code of the LiveMocha page with the video...you'll find a string like this:

        flashvars['videoUrl'] = 'http%3A%2F%2Fptr2.prod.cf.static-livemocha.com%2Fcommon2%2Fcontent%2Factive%2Fes-mx%2Fc_1%2Fv_100%2Fes_6_1.flv';

        It's easy to spot among the others as it ends in FLV.

        2) Convert the HTML entities back to text with an online tool like this: http://entities.online-toolz.com/tools/text-html-entities-convertor.php (second form)

        3) You'll get this, ready to be opened with VLC or any other video player:

        http://ptr2.prod.cf.static-livemocha.com/common2/content/active/es-mx/c_1/v_100/es_6_1.flv

        Thanks.

      • edgar navaedgar nava commented  · 

        I'm sick of livemocha. Could anyone tell me about another page to learn languages?

      • Anonymous commented  · 

        I wonder why does Live Mocha require Flash 11.3. Is it so cutting edge that requires the absolutely newest version? I believe they may be investing in the new, for now Chrome only, version but guys, you just need to remove an unnecessary verification!

      • blalablala commented  · 

        i use linux mint maya and i have problem with adobe flash player which is needed..

      • Anonymous commented  · 

        Linux users should boycott Live Mocha. I have sent them numerous emails regarding the version check script which bans Linux users from accessing the lessons (because it requires the absolute latest Flash), and they have not responded. I specifically asked them to let me know they read my email and they still refused. (this is as a paid user - I am being treated this bad as a paid user- just because I use Linux). It seems that the Live Mocha developers don’t know what they’re doing because to add a version check script and then outright deny access if the user doesn’t have the latest version is absurd. To think that Flash 11.2 wouldn’t work is even more absurd. Also they seem to have a vendetta against Linux.

      • Vanya KupalovVanya Kupalov commented  · 

        Using Chrome with it's own 11.5 flash. But not working properly.

      • Vanya KupalovVanya Kupalov commented  · 

        Ubuntu 12.10, Chrome 23 Stable.
        On chrome://plugins press detailed (top right corner) than croll to flash. You may see two flash plugins: one from Chrome and one from your system. I strongly recommend to disable system flash - it's outdated for me (11.2 against 11.5 from Chrome).
        BUT it still doesn't show kanji properly. What's the problem? And why do you use Flash?

      • ;2aven;2aven commented  · 

        ::: Solved :::

        *from: http://askubuntu.com/questions/167573/flashplayer-and-livemocha

        I did this steps and been able to use FlashPalayer in LiveMocha. This lines install the Google Chrome stable, that comes with FlashPlayer 11.4.

        Run wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -.

        gksu gedit /etc/apt/sources.list.d/google.list (opens a graphical text editor)

        Paste the text: deb http://dl.google.com/linux/chrome/deb/ stable main

        Run sudo apt-get update.

        Run sudo apt-get install google-chrome-stable.

      ← Previous 1 3

      Feedback and Knowledge Base